Настройка BLF

anonymous

Well-Known Member
Регистрация
14 Янв 2008
Сообщения
19.170
Пытаюсь настроить BLF для 3CX Phone в связке с BroadSoft

В Softkeys Configuration устанавливаю Type=BLF/XFer, User ID прописываю "fnc=sd+blf+cp;sub=line1", устанавливаю Label по вкусу, устанавливаю Account к которому привязан список.
В качестве User ID пробовал разные вариации "fnc=sd+blf+cp;sub=line1", "sub=line1" и т.п.

При этом кроме регистрации основной линии вижу еще два SUBSCRIBE
SUBSCRIBE sip:main@voip.***:5060;transport=UDP SIP/2.0
SUBSCRIBE sip:%23any-dn%23@voip.***:5060;transport=UDP SIP/2.0
На которые система отвечает
SIP/2.0 401 Unauthorized
а на попытку авторизоваться отвечает
SIP/2.0 403 Forbidden

При этом основная линия main@voip.*** нормально зарегистрировалась до этого и звонки с неё/на неё нормально идут.

Собственно несколько вопросов - почему нет SUBSCRIBE для line1 и куда копать?
P.S. как работает BLF знаю только из описания :)
 
В телефоне (в данный момент) используется один из самых простых вариантов "presence". Ничего "продвинутого" и ничего "проприетарного".
В документации по телефону нет ничего о "fnc=sd+blf+cp;sub=line1". Если бы такое было, то это было бы там отражено. Думаю, что для Broadsoft существуют телефоны, которые предоставляют доступ к дополнительным сервисам.

Телефон предоставляется в стиле "как есть". Нет никаких гарантий, что телефон будет предоставлять больше чем описано в документации. Так же, в документации точно указано, в каком окружении предоставляется та или иная функциональность.

Реализация телефона не привязана к 3CX PhoneSystem, но это не значит, что можно будет добиться лучшей функциональности при подключении к какой-либо другой системе. Хотя, в некоторых случаях, он может и "посоперничать" с другими независимыми разработками.

Эта информация предоставлена для того, чтобы сохранить Ваше время, которое может быть потрачено на "поиски серой кошки в тёмной комнате".

Спасибо за понимание
 
Суть басни такова - поставьте 3CX Phone System и не мучайтесь.
 
Спасибо за помощь и быстрый ответ в русской ветке, еще один плюс в вашу пользу, чтобы использовать 3CX в продакшне, а не только бесплатные версии для мелких офисов.
Вы подсказали ключевые слова для поисковиков, чтобы понять как работает BLF в 3CX Phone.

Чтение RFC4662 (ну и RFC4235/RFC3265) дало достаточно информации (ну и интернет в помощь).
По сути, единственная проприетарность там только в том, что список подписки задан жестко в виде #any-dn# (чего я не нашел ни в одном из стандартов, а символ # является спецсимволом), а дальше - софтфон ждет стандартный xml в ответе.





P.S. Да, я понимаю, что софтфон предоставляется AS-IS, но не надо передергивать.
Документация на телефон достаточно куцая, если Вы имеете в виду http: //www.3cx.com/VOIP/ip-phone-help/installation и остальные странички. Настройка функционала BLF там не описана вообще, только на форуме. Кстати строчки вида "fnc=sd+blf+cp;sub=line1" как раз и взялись из сообщений типа https://www.3cx.com/forums/blf-set-up-on-cisco-509g-17042.html, но там это относилось к Cisco аппаратам, а не к 3CX Phone.
Насчет "в каком окружении предоставляется та или иная функциональность" - на странице https://www.3cx.com/VOIP/voip-phone/ описано:
Connect 3CXPhone to a VoIP provider or to a VoIP PBX (for example 3CX Phone System) to make calls to any VoIP, mobile or landline number.
На странице описания функционала https://www.3cx.com/VOIP/sip-phone/
Works seamlessly as a SIP phone for 3CX Phone System for Windows, a software-based SIP PBX that completely replaces a traditional proprietary phone system.
И нигде нет прямых указаний, что какие-то вещи только проприетарные и будут работать ТОЛЬКО в 3СХ.
 
Да не передёргивал я, а просто дал точный и, как выяснилось, не совсем бесполезный ответ. Не надо так злиться :)
Использовать #any-dn# ни одним стандартом не запрещается. А то, что его менять нельзя в телефоне, то это не проприетарность, а ограничения конкретной реализации. Т.е. 3CX Phone подписывается на и другой подписки не предусмотрено.
 

Для администраторов

Статистика форума

Темы
44.766
Сообщения
233.685
Пользователи
78.501
Новый пользователь
Erich Gasser
#